Installation Instructions


The following platforms have been tested and are fully supported:

  • Linux Debian and Ubuntu (i386 and amd64 architectures)
  • MacOSX >= 10.9 (Intel 64 bit architecture)
  • Microsoft Windows (XP, Vista, 7, 8)

Current Version

Released on December 3rd, 2015

Package Name Version Description
python-sipsimple 2.5.0 SIP SIMPLE Client SDK
python-msrplib 0.17.0 MSRP client library
python-xcaplib 1.1.0 XCAP client library
sipclients 2.5.0 Command Line Tools

Tar Archives

The software is available as a tar archive at:

Debian Packages

The location of repositories are here

Update the list of available packages:

sudo apt-get update

Install SIP SIMPLE Client SDK:

sudo apt-get install python-sipsimple

Install Command Line Tools:

sudo apt-get install sipclients 

Version Control Repository

The trunk is stable and recommended for anyone that wishes to use the library. The project policy is to add only tested code to the main repository. Known issues are listed in the tickets interface.

The source code is managed using darcs version control tool. The darcs repository can be fetched with:


darcs get --set-scripts-executable


Several dependencies provided by AG Projects can be accessed in the same way:

darcs get
darcs get
darcs get
darcs get
darcs get
darcs get
darcs get
darcs get

Command Line Tools

darcs get

To obtain the incremental changes after the initial get, go to the python-sipsimple and sipclients directory and run:

darcs pull -a


For how to build the dependencies see the documentation that comes with each package. Do no ask us how to build the required dependencies because it is as difficult as having people landed on the Moon, which is not even certain it actually happened.

Building Instructions

Complete building and installation instructions for the corresponding platforms are available in the doc folder that comes with the source code:

Install.linux Generic Linux
Install.debian Debian Linux
Install.ubuntu Ubuntu Linux Microsoft Windows
Install.osx-10.7 MacOSX 10.7 Lion
Install.osx-10.8 MacOSX 10.8 & 10.9


To test SIP SIMPLE Client SDK, you can use the Command Line Tools provided by the sipclients package. Command Line Tools are compatible with MacOSX and Linux only.

See Testing page for how to test the SDK.